Microsoft Excel // =PRODUKT(3;3)=6

Problem gelöst oder benötigst du noch Hilfe?

Nicht hinbekommen.
SVERWEIS (A5 ; Tabellenblatt2! A2:A200; 2, FALSE)

Damit sollte doch geschaut werden, ob es auf Tabellenblatt 2 im Bereich A2-A200 einen entsprechenden Wert gibt, und dann der Rest da eingetragen werden, oder?

Jo. Überprüft wird der Wert in A5 (auf Tabellenblatt 1) innerhalb der Matrix auf Blatt 2. Zurückgegeben wird dann der Wert in der zweiten Spalte der Matrix von links.

In der Formel hast du vorm False ein Komma statt Semikolon. Reicht das schon, um den Fehler zu korrigieren?

Nope, auch mit richtigen Zeichen erscheint immer „Zirkelverweis“ oder „Bezug“.

Dann schick mir doch gerne noch mal einen Link zum Dokument, dann schaue ich es mir mal an. Klingt so, als verweist ein Teil der Formel noch irgendwo auf einen anderen, zu berechnenden Teil o. ä. Ich bin mir nicht sicher, ob das Anschalten der iterativen Berechnung das Problem lösen könnte (Notfalls: Set a spreadsheet’s location & calculation settings - Computer - Google Docs Editors Help).

Also A2:A200 in Verbindung mit Sverweis und der 2. Spalte kann nicht klappen, die Matrix braucht dann mindestens 2 spalten. Probier mal A2:B500. Stehen in Tabellenblatt 2 in Spalte A die cocktails und in Spalte B die Preise?

Und die oben genannte Spalte steht auch sicher auf Tabellenblatt 1? Stehen auf Tabellenblatt 2 nur harte Werte oder auch Verweise auf Tabellenblatt 1?

Ich versuche mich gerade in einem simplen Jahreskalender in Exel für das Jahr 2023.

Dieser hat für jede Woche die Tage von Montag bis Freitag und pro Wochentag je sechs Spalten für Namen.

Das Knifflige, oben Links steht eine Zeile mit der Woche des Jahres und darunter eine Zeile mit dem Datum von bis.

Beispiel:
01
02.01. - 06.01.

02
09.01. bis 13.01.

Ich gehe davon aus, dass dieser Kalender auch 2024 benutzt wird. Ich habe da wenig Lust, in einem Jahr wieder alle Wochen und alle Daten darin manuell zu überschreiben. Das muss doch einfacher gehen? Ich einem zusätzlichen Register habe ich auf die Schnell einen Jahreskalender erstellt. Darin trägt man nur das Jahr ein (also 2023) und Excel schreibt dann den Tag und das dazugehörige Datum bis Ende Jahr dazu.

Doch wie kriege ich die Felder Woche 01 und das Datum 02.01. - 06.01. in die Felder?

Jemand 'ne Idee? Wie kann ich auf diese gelben Summenzeilen verweisen?

Ist das in der kleinen Schrift oben die Fragestellung? Du willst den String so kürzen, dass nur die Kontonummer rauskommt? Falls die Kontonummer immer immer sechsstellig ist: „=RECHTS(A5;6)“

Nein. Das Problem ist dass in den ersten zwei Feldern 100009 stehen soll, in den nächsten zwei Feldern dann aber 100008. So wie die blauen Pfeile das zeigen.

Es soll also immer auf den übernächsten Text („Konto 100009“ etc.) in Spalte A verwiesen werden.

Ist schwierig zu erklären aber eigentlich ganz simpel gemeint.

Und das Problem ist, dass es eine sehr große Tabelle ist und du die Formel einfach runterkopieren möchtest?

1 „Gefällt mir“

Kopiere die folgende Formel nach A2, dann kannst du sie nach unten ziehen:

=WENN(REST(ZEILE(A2);5)=1;"";WENN(REST(ZEILE(A2);5)=2;INDIREKT("A"&ZEILE(A2)+3);WENN(REST(ZEILE(A2);5)=3;INDIREKT("A"&ZEILE(A2)+2);WENN(REST(ZEILE(A2);5)=4;"";""))))

Wenn das "Konto " vor der Zahl wegsoll, dann

=WENN(REST(ZEILE(A2);5)=1;"";WENN(REST(ZEILE(A2);5)=2;RECHTS(INDIREKT("A"&ZEILE(A2)+3);6);WENN(REST(ZEILE(A2);5)=3;RECHTS(INDIREKT("A"&ZEILE(A2)+2);6);WENN(REST(ZEILE(A2);5)=4;"";""))))